Debugging your Windows Store App, Error Message: “Unable to activate…”

debuggingError

“The activation request failed with error ‘This app failed to launch because of an issue with its license.  Please try again in a moment.’

This error message appears on occasion, and there seems to be some correlation to it’s appearance, and the last time the app was run.  However, I haven’t been able to determine exactly what that correlation is.  Sometimes it appears within a day, sometimes it’s several days.  There’s no problem with my developer license, it is active.

There have been a few other threads about this type of error on MSDN, and I haven’t seen one yet where the cause and/or correlation to time or other events is clearly defined.  So basically, we don’t know why or when it’s going to show up.

Fortunately, there’s an easy workaround.  Using File Explorer, navigate to your Visual Studio projects folder, and open the Solution folder.  From there, open the bin folder, select the Debug folder, and delete it.

Switch back to Visual Studio, and run your App.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s